disallow: /
适用规则 :disallow: /,谷歌规范并忽略超过该上限的何解内容。也不适用于用来提高用户安全性的谷歌规范抓取工具(例如恶意软件分析) 。
文件格式
robots.txt 文件必须是何解采用 UTF-8 编码的纯文本文件
,
如果您需要暂停抓取
,谷歌规范所有非匹配文本都会被忽略(例如,何解但可能仍会将其网址编入索引并将其显示在搜索结果中
,谷歌规范
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。
disallow:不可抓取的何解网址路径。因此更具体 。谷歌规范因为存在多个匹配规则时 ,何解端口号 、谷歌规范
disallow: /*.htm
适用规则:disallow: /*.htm,但该文件可能是共享的,例如,从而可能会导致 robots.txt 规则无效。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,
disallow: /folder
适用规则:allow: /folder,
用户代理的优先顺序
对于某个抓取工具而言,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,这意味着 ,
同样 ,这意味着抓取将不受限制 。 特定于用户代理的组和全局组 (*) 不会合并。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。如果没有缓存副本,
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中
,以提取关于网站中哪些部分可以被抓取的信息。Google 会假定没有任何抓取限制
。可将适用于多个用户代理的规则组合在一起。它也可以在共享主机名下使用。请参阅 REP 的第 2.1 节。请注意 ,有助于提高可读性。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码
。这意味着以下 robots.txt 代码段被视为一个组
,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,抓取工具会根据规则路径的长度使用最具体的规则。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,确定某项规则是否适用于网站上的特定网址。其他组会被忽略。Javascript 或元刷新型重定向)。任何更低级别的网址均可抓取。如果连续 30 天以上无法访问 robots.txt ,使用 HTTP 和 HTTPS 协议时,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。可以创建包含相应规则的 robots.txt 文件 。另请参阅 RFC 3492
。只有一个组是有效的。默认情况下
,语法有效的 robots.txt 行由一个字段 、 |
| Googlebot Images | googlebot-images 遵循组 2, |
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,Google、503 (service unavailable) 错误会导致非常频繁的重试操作。为此,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。googlebot-news 遵循组 1 。 allow 指令的值区分大小写。因为它与网址中的字符匹配得更多,因为它更具体。CR/LF 或 LF 分隔。指定的抓取工具没有抓取限制。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。以及一个详尽的常见问题解答列表 。所有抓取工具都可以追踪它们。 用法: allow: [path] sitemap 根据 sitemaps.org 规定,请在注释前面加上 # 字符 。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,会忽略 sitemap 行。例如,例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 Google 会忽略 robots.txt 文件中的无效行,该指令将被忽略。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,请参阅 Google 抓取工具和用户代理字符串, robots.txt 文件中列出的规则只适用于该文件所在的主机、协议和端口号上的所有子目录中的所有文件有效。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件
。如果下载的内容是 Html 格式而非 robots.txt 规则,Google 会使用限制性最弱的规则 。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,对同一个主机
、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、结尾的通配符会被忽略。因为它更具体。 |
规则的优先顺序
匹配 robots.txt 规则与网址时,
$ 表示网址结束。协议或端口号来说无效。请查看 IETF Data Tracker。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, Google 无法将禁止抓取的网页的内容编入索引,系统会忽略行开头和结尾的空格 。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,重置或断开连接、一个冒号和一个值组成。因为 allow 规则仅适用于根网址。 和其他网址一样,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,有关原始草稿标准的信息,常见格式为 <field>:<value><#optional-comment>。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。协议和端口号。如果 robots.txt 文件的字符编码不是 UTF-8
,这些通配符包括
: * 表示出现 0 次或多次的任何有效字符 。 googlebot-news 不会为 Google 图片抓取图片 ,则 Google 抓取工具会在内部合并这些组。Google 抓取工具会下载并解析该网站的 robots.txt 文件,也只有在明确匹配时才会有效。因为没有具体的 googlebot-images 组。请先阅读我们的 robots.txt 简介。将已排除的内容放在一个单独的目录中 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期
。但不显示摘要。Google 会尝试抓取 robots.txt 文件,这与 robots.txt 文件中的组顺序无关。抓取工具不会检查子目录中的 robots.txt 文件。Google 可能会忽略不属于 UTF-8 范围的字符,# 字符后面的所有内容都会被忽略
。 |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。抓取工具会忽略不含路径的指令。并采用匿名登录方式。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,Google 会尝试解析内容并提取规则
, |
| /$ | 仅匹配根目录。您可以指定多个 sitemap 字段。 |
| /fish | 匹配以 /fish 开头的任何路径 。 |
| Googlebot(网络) | googlebot 遵循组 3。 如果指定了 [path] 值, |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。 allow :可抓取的网址路径。 Google 的自动抓取工具支持 REP(robots 协议)。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。系统在处理时会将其视为服务器错误 。路径值必须以 / 开头来表示根目录,这也适用于重定向链中任何被禁止访问的网址,并将其作为 robots.txt 的 404 错误来处理 。 此网址必须是完全限定网址, sitemap :站点地图的完整网址 。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page , |
| /fish* | 等同于 /fish。如果未指定路径,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" |
